SPSS/PASW 17 and Mac OS X 10.6 (Snow Leopard)

I recently discovered that the statistical package of choice for political science students at UiO is not supported by the newest Mac OS X upgrade. But fear not – it might be possible for you to reap the benefits of both Snow Leopard and SPSS right now anyway. Here is how to do it!

First of all, this solution is in no way supported by the University of Oslo or any of its departments. I only offer this solution because it worked for me, there is no guarantee that this will work for you (and if you mess up, your computer could possibly be struck by lightning or something aweful…)

Second, in a month or two, we will hopefully have access to PASW 18 (if you didn’t get that already, SPSS has changed its name to PASW since version 17.0.2), and that is supposed to be supported by Snow Leopard – the latest version of Mac OS X. So, if you are in no rush, you can always wait. And, of course, if you are in no rush to install Snow Leopard, you could wait with that as well…

UiO students now have access to version 18, but since these instructions still are read frequently, I’ll leave the instructions here!

But if you’re like me, and do not want to be constrained by the upgrade policies, there is a way around this problem. It is a bit technical, so bear with me. I believe this solution works if you

  1. install PASW 17.0.2 before you upgrade to Snow Leopard (not performing an «erase-disk-and-performing-a-clean-install» upgrade), or
  2. have a time machine backup of your disk, and can restore the «SPSSInc» folder to your Applications’ folder.

I have not been able to make this work when trying to install PASW 17.0.2 «from scratch» on Snow Leopard. So, here is the rundown:

  1. Basically what you have to do, is install Java version 1.5.0 (Snow Leopard only ships with version 1.6.0). You can download the correct package from here. Put it in your «home» or «root» folder (the folder where you find all the other folders for your images, movies, documents, etc.)
  2. Open «Terminal» (it’s an application inside your Applications/Utilities folder (Programmer/Verktøy på norsk).
  3. Write the following command and press enter:
    sudo -s
  4. Say yes, and enter your administrator password (you should be logged in as an administrator to do this).
  5. Write the following commands (press enter after each line):
    cd /System/Library/Frameworks/JavaVM.framework/Versions
    scp ~/java.zip .
    rm -f 1.5*
    unzip java.zip
    ln -s 1.5.0 1.5
  6. You’re done!

3 tanker om “SPSS/PASW 17 and Mac OS X 10.6 (Snow Leopard)”

  1. Quick question: Does this change in Java have effect on all system wide use of JAVA? i.e. by following the steps, would all other apps in your Mac os 10.6 will be using java 1.5.0 instead of snow leopard default 1.6?

    Thanks!

    1. Nope – haven’t seen any changes in other programs. The thing is, you don’t delete the 1.6 version, you simply restore backwards compatibility with 1.5.0!

Legg igjen en kommentar

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *


*

Du kan bruke disse HTML-kodene og -egenskapene: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>